44 lines
1.3 KiB
Nix
44 lines
1.3 KiB
Nix
{
|
|
description = "Nix flake to use minindie static files as a theme for website deployment";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "github:NixOS/nixpkgs";
|
|
flake-utils.url = "github:numtide/flake-utils";
|
|
};
|
|
|
|
outputs = { self, nixpkgs, flake-utils, ... }:
|
|
flake-utils.lib.eachDefaultSystem (system:
|
|
let
|
|
pkgs = nixpkgs.legacyPackages.${system};
|
|
in {
|
|
packages = rec {
|
|
minindieTheme = pkgs.stdenv.mkDerivation {
|
|
pname = "minindie-theme";
|
|
version = "1.0.0";
|
|
|
|
src = ./.;
|
|
|
|
installPhase = ''
|
|
mkdir -p $out/themes/minindie
|
|
cp -r archetypes theme.toml layouts static $out/themes/minindie
|
|
'';
|
|
|
|
meta = with pkgs.lib; {
|
|
description = "Static files for the minindie theme to be used in the website deployment";
|
|
homepage = "https://your-homepage-url";
|
|
license = licenses.mit;
|
|
maintainers = [ maintainers.yourname ];
|
|
platforms = platforms.unix;
|
|
};
|
|
};
|
|
};
|
|
|
|
defaultPackage.${system} = self.packages.${system}.minindieTheme;
|
|
|
|
apps = rec {
|
|
minindieTheme = flake-utils.lib.mkApp { drv = self.packages.${system}.minindieTheme; };
|
|
default = minindieTheme;
|
|
};
|
|
}
|
|
);
|
|
}
|